Aggiornamento Chrome: ecco il bug di WooCommerce su Wordpress

Aggiornamento Chrome: ecco il bug di WooCommerce su Wordpress

Data di pubblicazione: 24-07-2015

Brutte notizie per gli utenti di WooCommerce: il nuovo aggiornamento di Google Chrome (Versione 44 o successive) ha messo in evidenza un bug che rende impossibile la corretta visualizzazione dei siti web che utilizzano il famoso CMS Wordpress insieme al plugin in questione.

In particolar modo il bug è dovuto a un invio errato nel header di richiesta della pagina che viene reindirizzata erroneamente verso una connessione https (connessione sicura del browser). Se non attiva, di conseguenza, la pagina non viene caricata correttamente.

COME RISOLVERE IL PROBLEMA

  1. Se si possiede una versione uguale o superiore alla 2.3.12 il problema non dovrebbe presentarsi. Altrimenti è sufficiente aggiornare alla versione più recente di WooCommerce:
  2. Se non potete aggiornare il plug-in editare il file wp content\plugins\woocommerce\woocommerce.php commentando le seguenti righe di codice:

if ( ! isset( $_SERVER['HTTPS'] ) && ! empty( $_SERVER['HTTP_HTTPS'] ) ) {

$_SERVER['HTTPS'] = $_SERVER['HTTP_HTTPS'];

}